Jump to content

Recommended Posts

Not sure if anyone else has noticed this but after the latest round of maintenance the 'Download Your Data' button is now working for me.  I'm one of the people for whom it has never worked in the past but now it is OK - I've not changed browser or anything else.  If it hasn't worked for you it might be worth giving it another try.



Link to post
Share on other sites
  • 2 weeks later...
3 hours ago, Niels Quist said:

Mine has not worked until now. Just now I clicked prepare download - and now it seems to prepare for download later, so hopefully it works.

I think my "preparation" only took seconds- you may have it by now!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.