Jump to content

Recommended Posts

I am on Chrome - I fill out the correct details and when I hit login the page just refreshes.  Searched the forum for similar and found a thread where someone turned off their ad-blocker.  I have turned off my ad-blocker and it makes no difference - the login page just refreshes (I at no point am seeing a captcha thing even with adblocker switched off)


Link to comment
Share on other sites

18 minutes ago, Starsphinx said:

Just tried on firefox and getting the same thing happen - and that does not even have an adblocker installed!!!!



No problems here with FF.




Link to comment
Share on other sites

If I logout and try to login from the Alamy home page, the login dialogue simply disappears and does nothing. Failure.


However, if I login from my usual link to the full login page, eveything is fine. Success.


I have a feeling this has happned before, some time ago.

Link to comment
Share on other sites

OK I have managed to sort it.  By restarting my PC and then clearing my browsing history first from an hour then a day then a week etc until I cleared all of it.  Just clicking clear all without going through the others first did not work - I had already tried that twice before shutting my machine down.

It is probably something on my machine but I do not have the foggiest idea what - nothing showing on anti virus or anti scum or cleaner or anything.  Still everything here is working again.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.