Jump to content

Macintosh Madness


Recommended Posts

I solved one problem on my MacBook Air but created 6 or 7 new problems. The problem I solved: my keyboard was not typing the same thing that was on the keys. ? was a hyphen, * was 8, and so on. There were a dozen keys like this. Liverpool One Apple people had never seen it before. 

 

I thought if I could return to the factory preset, the keyboard would be right. So I reloaded the OS. It was hell to do but when I finally got it done yesterday, I found that I had screwed up some other things. 

 

One: I deleted a bunch of files on my Air's desktop. Fine . . . but those files where also deleted from my MacBook Pro. The Pro was turned off but when I turned it on those files were gone. I downloaded Disk drill but when I tried to restore the files they said I needed Disk drill Pro ($$) to do it. 

 

Two: I can't get the WiFi in my building on the Air. The Air won't accept the building WiFi's password. They want me to put in a WPA2 network password. What's that??? I walked the Air over to Apple and from outside the store I was able to get on their WiFi. I will try to book an appointment with them next week. 

 

All this stuff has me brain dead. 

 

 

Link to comment
Share on other sites

Ed, first you have to find your routers IP address.

 

This website gives you the instructions how to do that on a Mac. (it shows Windows first, just scroll down).

 

Then you have to get your WPA2 key.

 

Copied and pasted this from another site:  

  • In most cases, you can also obtain your network's WPA2 key by logging in to the router's configuration page. Open a browser and type your router's IP address (often 192.168.0.1 or 192.168.1.1). Press "Return," and then type the administrator username and password for the router. If you need to find your network's WPA2 key because you are unable to connect to it using your Mac's AirPort menu, connect the Mac to the router with an Ethernet cable to log in to the configuration page and recover the WPA2 key. Consult the router's instruction manual for more information.

Hope this was helpful.

 

Jill

Link to comment
Share on other sites

Edo. For the WiFi problem, turn off and the turn on WiFi where the computer should automatically search and find the network among any ava networks. In the dialog box that appears, under the Security drop down box, just select WPA2/WPA3 Personal (or WPA/WPA2), then type your password. That should do it I think. The WPA stuff is a security protocol. 
 

For the keyboard problem I haven’t got a clue. If you reformatted the drive which may have happened during the reinstall , then chances are the files are gone. 

Edited by MDM
Link to comment
Share on other sites

Thank you for getting back to me, Northern Lass and Irish Lad. Most of what you suggest I've tried but either don't have enough of the needed info or it does not work. I did fix the keyboard problem. 🙂

 

Poco a poco . . . a poco. In Italiano, piano piano. Ohmygosh—tomorrow is blog day! 🤔

Edited by Ed Rooney
Link to comment
Share on other sites

7 minutes ago, Ed Rooney said:

Thank you for getting back to me, Northern Lass and Irish Lad. Most of what you suggest I've tried but either don't have enough of the needed info or it does not work. I did fix the keyboard problem. 🙂

 

Poco a poco . . . a poco. In Italiano, piano piano. Ohmygosh—tomorrow is blog day! 🤔

 

What sort of error message are you getting when you put in the password Edo? 

Link to comment
Share on other sites

This happened to me once Ed.  Trouble is I'm trying to remember the fix.  Have you unplugged router and/or modem? Leave for a couple of minutes then plug back in.  The your computer has to refind the networks.  Might be worth a try.

 

Jill

Link to comment
Share on other sites

29 minutes ago, Jill Morgan said:

This happened to me once Ed.  Trouble is I'm trying to remember the fix.  Have you unplugged router and/or modem? Leave for a couple of minutes then plug back in.  The your computer has to refind the networks.  Might be worth a try.

 

Jill

 

Edo can correct me if I am wrong but I think the wifi is for the entire building so he probably does not have access to the router? 

Link to comment
Share on other sites

Just now, Jill Morgan said:

 

Well, that sucks.

 

Jill

 

Not necessarily. It's a normal way of doing things. Like in a hotel one central router for the building. Of course if Edo has his own router then I am wrong and I will eat my words.

Link to comment
Share on other sites

Just now, MDM said:

 

Not necessarily. It's a normal way of doing things. Like in a hotel one central router for the building. Of course if Edo has his own router then I am wrong and I will eat my words.

 

Just meant in terms of possibly fixing the issue. I'm sure it saves everyone in the building a lot of money.

 

Jill

Link to comment
Share on other sites

Michael is right, Jill. I'm in a building that is part hotel (was?) and part apartments. There was a management change a month ago. This MacBook Pro I'm typing on is still ok with the building's WiFi. 

 

Michael, the sign-in won't accept my password. It says The WiFi network requires a WPA2 password. 

Link to comment
Share on other sites

4 minutes ago, Ed Rooney said:

Michael is right, Jill. I'm in a building that is part hotel (was?) and part apartments. There was a management change a month ago. This MacBook Pro I'm typing on is still ok with the building's WiFi. 

 

Michael, the sign-in won't accept my password. It says The WiFi network requires a WPA2 password. 

 Phew I can keep the mask on for now.  It should be very straightforward Edo. You should just need to select WPA2 from a list of security options when you allow the computer to search for networks. If you can't figure it and want me to talk you through it, email me your phone number and I will ring you (tomorrow anytime you like). Or those friends of yours in the Apple Store could show you.

Link to comment
Share on other sites

No hurry Edo. I am just on my first coffee of the day. And no pressure to do a call. However, it can be a bit easier to explain by walking someone through the process but it really should not be difficult. When you search and find the network, in the dialog box that asks you for the password, you should be able to choose WPA2 from a dropdown box titled Security and then enter your password. 

Link to comment
Share on other sites

Edo I realise you may be getting your wifi/internet connection for "free" but there may be an element added to your rent for its use in private residences.

 

May i suggest you investigate "Mobile broadband dongle".

 

I use a mobile dongle from "3" on my desktop with 40GB of data/mth at a cost of £13/mth. This is a secure internet/wifi connection which has the advantage that I can take it with me when I go away for a while and use it with my laptop. I prefer to use it with my laptop in coffee houses etc too which offer free wifi which is not really secure. No one else can use my connection without me giving them the pass code.

 

I have not yet run out of data the 40GB data limit in any one month and probably only use 20 - 25GB of that most months. In all the places in the country I have used this dongle I have always had a good connection.

 

Allan

 

Link to comment
Share on other sites

I will check out your dongle suggestion, Allan, but I don't think that's the answer. As you see, I can get on the Web with the MacBook Pro I'm using. The building's WiFi works and my Personal Hotspot from THREE also works. The problem is with the MacBook Air. 

 

https://edostrange.blogspot.com/2020/09/fast-food.html

 

 

 

Link to comment
Share on other sites

Hi Edo. It was nice to have that chat on the phone. Having tried what we tried, my guess is that it is a problem with the actual password as I can't think of anything else that it could be. See if you can get the password from someone else.

 

This is the procedure for reference. 

Hit Join Other Network in the menu bar, make sure you check WPA2/WPA3 Personal or WPA1/WPA2 Personal in the Security box, Type the Network Name in the top box and the password in the bottom box. Alternatively click Show Networks at the bottom left after you have selected the Security option, allow it to find the network and then type the password.  That should definitely work as long as you have the correct password. 

Link to comment
Share on other sites

Yes, it was good to chat. 

 

I would agree with the problem being the password but . . .

 

On my Pro, where I'm writing this, I have a second way to get online: the Personal Hotspot on my iPhone with THREE. That is on my Pro but not on my Air. 'Tis a puzzelment. 

 

Link to comment
Share on other sites

12 minutes ago, Ed Rooney said:

Yes, it was good to chat. 

 

I would agree with the problem being the password but . . .

 

On my Pro, where I'm writing this, I have a second way to get online: the Personal Hotspot on my iPhone with THREE. That is on my Pro but not on my Air. 'Tis a puzzelment. 

 

 

On the menu bar WiFi icon, click Open Network Prefs and see if Ask to Join Personal Hotspots is checked. I don't use this but I just tried it and it worked for me.

Link to comment
Share on other sites

Putting 3 and 4 together, does your password have special characters in it? If so, is it possible your Mac still isn’t typing all the right characters, so your password keeps being rejected? Maybe turn on the keyboard viewer to check what special characters are on which keys?

 

Mark

Edited by M.Chapman
Link to comment
Share on other sites

Ah ha! I have found solution to the problems involved in getting my MacBook Air online. Well . . . more a sort of partial solution. What was it I said in this forum recently? The path to success is lined with failures. I've been at this since before breakfast this morning. Michael (MDM) was kind enough to call me and talk me through basic procedures. He was spot on. My Air, unfortunately, was not. None of the logical steps of getting this Mac online worked. I'm typing this on my Pro, but I've been online on my Air.

 

This is what I did and where I am:

 

Since I couldn't get anywhere trying to connect with the WiFi in my building, I focused on connecting through the Personal Hotspot on my iPhone. I have unlimited data. Again I got stuck in a password swamp. So I connected my phone to the computer with the USB cable. Bingo! Now all I have to do is find my way with a 100 more tech problems and I'm home free. 🤪

Link to comment
Share on other sites

2 hours ago, Ed Rooney said:

Ah ha! I have found solution to the problems involved in getting my MacBook Air online. Well . . . more a sort of partial solution. What was it I said in this forum recently? The path to success is lined with failures. I've been at this since before breakfast this morning. Michael (MDM) was kind enough to call me and talk me through basic procedures. He was spot on. My Air, unfortunately, was not. None of the logical steps of getting this Mac online worked. I'm typing this on my Pro, but I've been online on my Air.

 

This is what I did and where I am:

 

Since I couldn't get anywhere trying to connect with the WiFi in my building, I focused on connecting through the Personal Hotspot on my iPhone. I have unlimited data. Again I got stuck in a password swamp. So I connected my phone to the computer with the USB cable. Bingo! Now all I have to do is find my way with a 100 more tech problems and I'm home free. 🤪

 

Interesting Edo. I don't use personal hotspot but good to know you can connect it directly to the computer. I wonder why you had a problem with the password again though as it tells you what password to use. This does not make sense really. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.