Jump to content
Sign in to follow this  
Starsphinx

What has happened to camera bits?

Recommended Posts

Just been to look at some photomechanic stuff - and I cannot get their website.  I either get a hosts placeholder page (adverts) or a cannot reach this site message.  I have checked links through google. facebook, and twitter and am getting the same result on all.

Please tell me that they have not disappeared?  Photo Mechanic is essential - and not just for me I have never heard anyone say anything bad about it and I know people rely on it.  Anyone know what is going on?

 

Share this post


Link to post
Share on other sites

No problem getting the site up here.

Share this post


Link to post
Share on other sites

Thank goodness for that.  It just means it is another stupid idiotic bleeping issue with my computer/modem/internet.  I can fix those. Surviving without photo mechanic would be a tad more challenging lol.

Thank you everyone.

Share this post


Link to post
Share on other sites
Posted (edited)

I too am having access issues from my Android tablet. Will check desktop shortly - same problem. Not much activity about the problem on Twitter.

 
Edited by Martin P Wilson
Update

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, Harry Harrison said:

Working for me:

 

https://home.camerabits.com

 

That link won't work for me. Hopefully they haven't gone to bits.

Edited by John Mitchell
  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Martin P Wilson said:

I too am having access issues from my Android tablet. Will check desktop shortly - same problem. Not much activity about the problem on Twitter.

 

I thought I recognized you on Twitter lol

 

Share this post


Link to post
Share on other sites

OK the site is now working for me - I am guessing it is going to be some sort of problem with their hosts.

Share this post


Link to post
Share on other sites

I usually have a quick look at the forum around once a month, just did and all was ok. Likely fixed now anyway as the last post here was 9 hours ago. Interesting reading comments on trialling C1 with PM, as was thinking of doing same. Initial thoughts, do I have time.

Share this post


Link to post
Share on other sites

I see that there was a problem, they posted this on Twitter:

 

The Camera Bits website is currently down. We are aware of the problem and working to fix it ASAP. Activating Photo Mechanic on new computers may not work as expected.

Share this post


Link to post
Share on other sites

My main worry was them disappearing full stop lol - I think it incredibly unlikely, but then nobody expected Woolworths to disappear.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.