Jump to content

Can't login to My Alamy using Chrome

Recommended Posts

No Mick, it isn't just you.  I am on Chrome too and I just tried to log in after successfully logging in this morning. The red message kept appearing each time I

re-entered the information.  This happened 4 times and the 5th time I tried because I couldn't believe I was getting it wrong, it worked.  So who knows what

is going on with the log in at present.


I still have to log in every day when I try to click on the bookmark.  Other bookmarks work fine.  Not Alamy's.  I no longer think it is the google problem that

was suggested earlier in the week.




Kathy deWitt

Link to comment
Share on other sites

Chrome isn't working for me either. I even changed my password to make sure that I used the correct one to log in, but it still doesn't work on Chrome. Works fine on IE, though. When I try to log in using Chrome I can see the My Alamy menu in the top right corner, but when I open the menu and select My Alamy from there, I'm taken back to the login screen instead of my Dashboard.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.