Jump to content

New Lightroom CC Classic worse or not?


Recommended Posts

At first I was surprised by the last version of Lightroom - CC Classic, at last the switching between pictures and even between Library and Develop module was swift...

 

But soon after I discovered that it is unstable and full of bugs...

 

I'm running it on a fairly new PC...

 

Latest bug: can't see the photo in the develop module???

 

Anyone, same experience?

 

Link to comment
Share on other sites

I've found a couple of bugs.

 

1 - if you are in Develop Mode, and you use Transform (with constrain crop), if you change your mind and press reset, nothing happens. However, if you come out of LR and go back in, the image has been reset.

 

2 - in Develop or Library Mode if you delete an image it doesn't disappear

 

John.

Link to comment
Share on other sites

44 minutes ago, Stokie said:

I've found a couple of bugs.

 

1 - if you are in Develop Mode, and you use Transform (with constrain crop), if you change your mind and press reset, nothing happens. However, if you come out of LR and go back in, the image has been reset.

 

2 - in Develop or Library Mode if you delete an image it doesn't disappear

 

John.

 

I'm not seeing  this behaviour - both the crop reset and the global reset work as they are supposed to do. Deleting images also works as before. I'm on a Mac, MacOs Sierra 10.12.5. There is an Adobe forum for reporting bugs. It would be worth checking there to see if there are any problems.

 

Also I'm also not seeing any other bugs. All is normal - no crashes. I've not really checked out whether it is faster than the previous version but it is reported to be. It is certainly quicker for culling a batch of images using the embedded previews feature.

Link to comment
Share on other sites

4 hours ago, LawrensonPhoto said:

It's crap, how on earth do you introduce more bugs than you've already ironed out :huh:

 

That seems a little harsh.  No issues at all on my 8 year old Mac Pro running El Capitan, 10.11.6.  It seems a little faster.  I will have to upgrade my computer shortly though as my model is now the bare minimum to run Lr CC Classic.

Link to comment
Share on other sites

59 minutes ago, MDM said:

It seems that the Windows version might be more buggy than the Mac one from a quick read around other forums.

 

Yes, I'm on Windows 7.

 

I might have a look at other forums to see if anybody else has had the problems i've had. Neither of which are any big deal, but they worked fine before the update!

 

John.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.