Jump to content
cbimages

Can't log on with Chrome

Recommended Posts

Can't log on to to Alamy, or to the forum with Chrome + win 7. Was fine 4 hours ago, but not now. Can however, do a search using Chrome from the login page. Using Opera right now & can log on to both without problem. Anyone else having this issue?

Share this post


Link to post
Share on other sites

duh, now it's working (ripping hair out in frustration!)

Share this post


Link to post
Share on other sites

I absolutely can't log in to my dashboard on Chrome, Mac. Like you, I get the home page and can search.

i have to use Firefox to access My Dashboard.

It's been like this for days. With Chrome, it won't accept my log in info.

 

I don't think the problem is on our end. There's too many of us griping, and the mess started after the forum being down and worked on.  Yet others are having no problem.

Betty

  • Upvote 1

Share this post


Link to post
Share on other sites

Safari on a Mac doesn't work either.

Share this post


Link to post
Share on other sites
5 hours ago, cbimages said:

Can't log on to to Alamy, or to the forum with Chrome + win

7. Was fine 4 hours ago, but not now. Can however, do a search using Chrome from the login page. Using Opera right now & can log on to both without problem. Anyone else having this issue?

 

Oh yes! Can't log in right now on my laptop using the same combination as you, only if using Mozilla Firefox.

Also, sometimes I'm happily logged in doing things when I get a pop-up 'Can't contact Capcha - check your Internet connection'. Eh??

 

Gen

Share this post


Link to post
Share on other sites

Not limited to Chrome, Safari for me... I've had to download Firefox to use if I want to login to Alamy.... don't use it for anything else.

 

Another annoying thing. When you're viewing the Forums and want to return to the Main Alamy site, you used to be able to click on the Alamy logo at the top (radical I know) and it would take you there. Now, it just takes you to the main forum screen..... the same as clicking on "Forum Home". They seem to be introducing more bugs than ever. I dread to think how many new clients (or even existing ones) have just given in with the login screens when creating / accessing their accounts!

Edited by Duncan_Andison
typo
  • Upvote 1

Share this post


Link to post
Share on other sites

I am managing to log in with Safari on my Mac but it's not straight forward and doesn't work reliably.  The main problem I'm finding is trying to log in on my iPad or iPhone.  Those stupid photos are poor and too small to see clearly sometimes so I just end up going round in a loop before the whole thing freezes up.  I had to shut my phone down yesterday to clear it then start again.  

As Duncan suggested above, how many clients are being lost through this?

Come on Alamy.  Surely you can do better than this.

 

Pearl

Share this post


Link to post
Share on other sites
40 minutes ago, Pearl said:

The main problem I'm finding is trying to log in on my iPad or iPhone.  Those stupid photos are poor and too small to see clearly sometimes so I just end up going round in a loop before the whole thing freezes up.  I had to shut my phone down yesterday to clear it then start again.  

Does this help? See my posting

 

  • Upvote 1

Share this post


Link to post
Share on other sites

I'm sorry...it's not Chrome, but Safari on my Mac that I can't log on with. Just Firefox.

And now I'm getting the car/sign boxes.

Share this post


Link to post
Share on other sites

Hi All

 

If I have to click another image of an out of focus sign ill go mad you can't log in on your iPhone or iPad and even on my Mac it took 2 attempts clicking on signs.

 

Come on alma sort this out .

 

 

Jon

  • Upvote 2

Share this post


Link to post
Share on other sites

The Captcha thing is ridiculous, I'm on windows 7 & Chrome and after putting in my password the captcha has come up three times in total, twice just now first after logging in to Alamy & now again, for the forum, It worked straight away yesterday, but today it's being difficult! 

Also, the fact you have to go to contact us, then click on Alamy is stupid!

 

Yet more trauma from Alamy in 2017 why?

  • Upvote 1

Share this post


Link to post
Share on other sites

The captcha mess has come to Firefox too. So far only for the forum for me.

 

wim

 

  • Upvote 1

Share this post


Link to post
Share on other sites

Although I already reported the problems I'm having with logging in, I decided to jump in again as it was a new one on me this morning. So just in order to report it, I had to log on to the Forum, going twice full circle and selecting a temple as 'Castle' ?

 

Anyway, here I am to moan again. The split second I click on 'login', I get 'cannot contact CAPCHA'. Then I was asked to select cars in the squares. Yeah I thought, 3 neat cars slap bang in the middle of squares, no sticking out, no dispute. As soon as I clicked on the squares, not only the images were not selected, but they all changed!! Verify box disappeared, I had to close the session and start all over again ???

 

This is Safari on iPad by the way.

 

gen

Share this post


Link to post
Share on other sites

Forever, I've used Safari to log onto Alamy on my Mac. I can get the home page, but nothing else. Just doesn't work. 

I can use Safari on my iPad, and it works. Sometimes I have to do the pictures, but so far (knock on wood) I've not been shut out on the iPad.

But I don't upload from my iPad. That's Mac work. 

Firefox works on my Mac, but I should be able to use my browser of choice. Why has everything been made difficult?

So much for speed. So much for smooth.  What has been changed to cause this? Is it Captcha keeping Safari from working? 

Does Safari have a security weakness concerning Alamy?

I can accept change if it's logical and I'm informed.

Betty

  • Upvote 1

Share this post


Link to post
Share on other sites

Could this be just a security measure against the recent ransomware outbreaks?

Still strange that Firefox was not affected for some time, but now it's on FF too.

Also strange that I do not have to click images to get to the main Alamy pages, just for access to the forum.

 

wim

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.