Jump to content
Sign in to follow this  
Mick Gosling

Can't login to My Alamy using Chrome

Recommended Posts

For the past few days I have not been able to login to My Alamy using the Chrome browser. IE works and I have managed to get onto these forums using Chrome but not into My Alamy. Is it just me?

Share this post


Link to post
Share on other sites

No Mick, it isn't just you.  I am on Chrome too and I just tried to log in after successfully logging in this morning. The red message kept appearing each time I

re-entered the information.  This happened 4 times and the 5th time I tried because I couldn't believe I was getting it wrong, it worked.  So who knows what

is going on with the log in at present.

 

I still have to log in every day when I try to click on the bookmark.  Other bookmarks work fine.  Not Alamy's.  I no longer think it is the google problem that

was suggested earlier in the week.

 

 

 

Kathy deWitt

Share this post


Link to post
Share on other sites

I have no trouble with Chrome in My Alamy. Always signs me in automatically using my bookmarks. I do however have to sign in to the forum every day.

 

Jill

Share this post


Link to post
Share on other sites

No problems at all with chrome, either for my alamy or the forum

Share this post


Link to post
Share on other sites

Chrome isn't working for me either. I even changed my password to make sure that I used the correct one to log in, but it still doesn't work on Chrome. Works fine on IE, though. When I try to log in using Chrome I can see the My Alamy menu in the top right corner, but when I open the menu and select My Alamy from there, I'm taken back to the login screen instead of my Dashboard.

Share this post


Link to post
Share on other sites

I had a problem logging in the other day using Chrome but today everything seems fine. I'm running Chrome Version 43.0.2357.124 (64-bit)) on my Mac Mini under Yosemite.

Share this post


Link to post
Share on other sites

I think clearing the browser cache helped. But it's kind of weird that it did because I just did that a couple of days ago and haven't logged into Alamy since then. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.