Jump to content

Recommended Posts

I am having trouble logging on to members services in order to send am e-mail. Have Alamy changed the system in some way?

I key in my normal log on pass word which it then rejects, Any ideas please.

Share this post


Link to post
Share on other sites

I don't exactly know what you mean by logging on to members services. As always you should just e-mail members services at the usual e-mail address - as far as I know. And for the sake of good order you should receive an automatic reply within hours that your e-mail has been received...

 

Niels

Edited by Niels Quist

Share this post


Link to post
Share on other sites

Just send an email to memberservices@alamy.com

Share this post


Link to post
Share on other sites

Hi Les - how come you are a Newbie with an impressive 15,525 images?

 

Well done you.

 

dov

Share this post


Link to post
Share on other sites

Hi Les - how come you are a Newbie with an impressive 15,525 images?

 

Well done you.

 

dov

He's a veteran of some nine years - just does not spend/invest (!) much time here......

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.