Jump to content

Search the Community

Showing results for tags 'poor contributor service'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Alamy Forum guidelines and announcements
    • Forum guidelines
    • Announcements
  • Alamy discussion and community support
    • Introductions
    • Portfolio critique
    • Community support: ask the forum
    • Stock photography discussion and contributor experience
    • Alamy Quality Control and technical talk
    • Let's talk about pics
  • Suggestions and ideas
    • Alamy
    • The Forum

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Alamy URL


Images


Joined Alamy

Found 1 result

  1. I found an unreported in-use in the TLS, used in Septermber 2020, on 11th June, and immediately did all the work to fill in the unreported use form. Alamy's answer: "We'll ask the customer's account handler to look into this and we'll get back to you." Nothing by19th July, so follow-up email: "Any word on this yet? I wouldn't have thought it would be difficult to chase up given that they have an "account handler". Alamy's answer: "We've just chased our colleague about this - apologies for the delay. We'll get back to you once we have an update." Nothing by yesterday (23rd Augus
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.